Jump to content

Ignition check oddity?


2High2Fast

Recommended Posts

Hello, all.

When I run-up to 2000 rpm and check my ignitions for independent operation, I get about 150 rpm drop when operating the mag, and about 50 or so when running the electronic alone. But when I switch from the Lightspeed back to both, I get a pronounced stutter with accompanying airframe shudder (torque). It may be a backfire, but I can’t hear it. It’s very consistent, (every time, exactly the same), but this is my first operation with electronic ignition in a Lycoming engine, so I’m not sure what’s up.

Thoughts?

Link to comment
Share on other sites

More clues, Dr. Watson.   Impulse mag or non-?  Using a key switch or toggles? Tried leaning the mixture?  What sort of LSE triggers are you using?  How do you start up and how does it work after starting?    How's the engine run when switching ignitions in idle.  How about when going from idle to higher RPM on only one ignition?  I think you would hear a backfire.

Edited by Kent Ashton

-Kent
Cozy IV N13AM-750 hrs, Long-EZ-85 hrs and sold

Link to comment
Share on other sites

17 hours ago, Kent Ashton said:

More clues, Dr. Watson.   Impulse mag or non-?  Using a key switch or toggles? Tried leaning the mixture?  What sort of LSE triggers are you using?  How do you start up and how does it work after starting?    How's the engine run when switching ignitions in idle.  How about when going from idle to higher RPM on only one ignition?  I think you would hear a backfire.

Not sure if impulse or non (I’ll try starting with the LSE ignition off), key switch, leaning makes no difference, triggers?, start with key - starts easily, idles well, haven’t tried at idle

Link to comment
Share on other sites

An impulse mag will snap or click as the spring winds up and trips the pawl(?) inside.  It is possible to time them wrong.  See  https://vansairforce.com/community/showthread.php?t=159907    It's not good to start on a non-impulse mag because it fires before TDC and can backfire and ruin you starter.   Lightspeed recommends toggles because key switches are subject to miswiring.   Lightspeed uses on of three kinds of triggers:  The Mini-sensor, or the green plastic ring or the Hall Effect mag-hole trigger.  http://lightspeed-aero.com/

I can't tell what you have wrong but I suspect it is the mag or timing.  However some of the LSE Plasma boxes have had a problem with broken solder joints inside and had to be repaired.  I imagine you can call them with your serial number and they can advise.

  • Thanks 1

-Kent
Cozy IV N13AM-750 hrs, Long-EZ-85 hrs and sold

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information